Ich habe folgende Hardware im Müll/Schrott gefunden

Diskussionen über alte Hardware
Antworten
Benutzeravatar
False Pr0phet
Tape Wechsler
Beiträge: 91
Registriert: Mo Mai 15, 2023 8:55 pm
Has thanked: 12 times
Been thanked: 20 times

Ich habe folgende Hardware im Müll/Schrott gefunden

Beitrag von False Pr0phet »

Grüß euch,

vor ca. ner Woche habe ich doch tatsächlich im Müllcontainer ein Retro-Fujitsu-NAS gefunden mit USB 3.0 und VGA sowie 2x LAN - womöglich Gigabit.

Es handelt sich um ein Fujitsu Celvin Q800 - Baugleich QNAP und andere.

Es hat einen Intel Atom D525 Dual-Core 64 Bit verbaut. Wegen der CPU-Leistung und den fehlenden AES-Instruktionen sind verschlüsselte Festplatten eher ein No-Go (TM). Aber als reines Daten-Grab ohne Verschlüsselung völlig brauchbar. Man kann ja auf Client-Seite EncFS nutzen sodass der Client die Daten vorverschlüsselt und auf das NAS ohne dessen CPU zu beanspruchen dann wieder sicher verschlüsselt ablegen kann. Alle moderneren CPUs auf Clientseite besitzen schon die AES-Instruktionen und es gibt hier auch keinen Flaschenhals.

So kann das NAS als ZFS-Datengrab (ggf. LZ4 Kompression deaktivieren) mit ordentlichem Netzwerkdurchsatz nutzen.

Man muss nur bedenken dass das System keine Möglichkeit besitzt von den Festplatten zu booten (Linux on ZFS z.B.) und es muss hier zwingend ein USB-Bootmedium als Bootquelle verwendet werden. Hier kann man auf dem USB-Stick einen MBR-Bootloader einrichten um dann doch den Bootsektor der Festplatten auszuführen.

Wie man sieht ist dieses Retro-NAS mit EncFS doch brauchbar nutzbar ohne dass dessen CPU schwitzen muss.

Hier nun die Bilder:
photo_2023-06-05_22-30-01.jpg
photo_2023-06-05_22-29-47.jpg
Das NAS war in einem fast staublosen Zustand - Es stand wohl in einem klimatisierten Serverraum.

photo_2023-06-05_22-29-55.jpg
Das Netzteil von Delta ist nicht zu verachten und sah aus wie neu.

photo_2023-06-05_22-30-08.jpg
photo_2023-06-05_22-30-14.jpg
Hier wurde versucht den LAN1-Port mit einem Flachschraubenzieher zu "bearbeiten" sodass dort diese Schnittstelle deaktiviert ist. Und bei diesem NAS ist der LAN1-Port der Haupt-Setup-Port. Habe das wieder hinbekommen und der Port funktioniert wieder einwandfrei.

photo_2023-06-05_22-30-21.jpg
photo_2023-06-05_22-30-27.jpg
Eine ordentliche Restauration der Kühlung war für mich selbstverständlich. Hier nutze ich für den CPU-Part die MX-4 Paste und für den Chipset eine Standard-Mosfet-Wärmeleitpaste.

photo_2023-06-05_22-30-31.jpg
Alle Hotplug-SATA Ports laufen einwandfrei und die Retro-NAS wurde ca. 1 Stunde mit ZFS Verschlüsselung und LZ4 gequält als Belastungstest mit 4x 500GB Sata Festplatten. Dementsprechend waren die Datendurchsätze aber dies hat den Stresstest bestanden.

Zusätzlich wurden der 1 GB Werks-RAM dank Dual-DDR3-SO-DiMM Slot auf 4 GB erweitert. Zusätzlich war die CMOS-Batterie leer und wurde auch ersetzt.

Der 512MB DOM wurde entfernt da dieser sich unregelmäßig vom USB Bus abgemeldet hatte. Dies war sehr wahrscheinlich der Hauptgrund für das Entsorgen. Da das NAS nur von USB booten kann braucht man nicht zwingend den 512MB DOM.

Das NAS hat eine PCIe-Backplane mit integrierten SATA-BUS-PCIe-Bridges mit eigener Stromversorgung vom Netzteil. Hier denke ich dass dies schon das bereinigte NAS ist wo hier wohl nicht das Mosfet-Problem auftritt.

Als Datengrab / EncFS-Grab durchaus zu gebrauchen - und für Free :D

Gruß
:mrgreen: False ( ͡° ͜ʖ ͡° ) Pr0phet :mrgreen:

Falscher Prophet mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
Status: Don't mess with the False Pr0phet / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
Benutzeravatar
False Pr0phet
Tape Wechsler
Beiträge: 91
Registriert: Mo Mai 15, 2023 8:55 pm
Has thanked: 12 times
Been thanked: 20 times

Re: Ich habe folgende Hardware im Müll/Schrott gefunden

Beitrag von False Pr0phet »

Beim heutigen eSchrott-Entsorgen ist mir was ganz besonderes in der Ecke - sauber aufgestellt - aufgefallen:

Eine Seagate ST-124:
photo_2023-06-07_22-54-35.jpg
photo_2023-06-07_22-54-40.jpg
Leider macht die Festplatte nur einen kleinen Mini-Klick ohne das der Spindelmotor hochfährt geschweige die
Köpfe initialisieren.

Die Festplatte sieht äußerlich im absoluten NOS-Zustand aus und ein Blick auf das PCB zeigt:
photo_2023-06-07_22-54-45.jpg
photo_2023-06-07_22-54-45.jpg (46.28 KiB) 15470 mal betrachtet
Der Laufwerksmotor ist sehr leichtgängig und auch die Köpfe waren nicht angeklebt.

Hier vermute ich die Elkos da ja der Elko neben dem Stepper-Driver ganz besonders hervorsticht.

Auf alle Fälle benötigt das PCB einen Standard-Service :D

Mal sehen.
:mrgreen: False ( ͡° ͜ʖ ͡° ) Pr0phet :mrgreen:

Falscher Prophet mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
Status: Don't mess with the False Pr0phet / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
Benutzeravatar
matze79
Norton Commander
Beiträge: 180
Registriert: So Mai 14, 2023 4:50 pm
Wohnort: Oberfranken
Has thanked: 20 times
Been thanked: 34 times
Kontaktdaten:

Re: Ich habe folgende Hardware im Müll/Schrott gefunden

Beitrag von matze79 »

Super Fund, wann gibt es den Funktionstest ? :D
Benutzeravatar
False Pr0phet
Tape Wechsler
Beiträge: 91
Registriert: Mo Mai 15, 2023 8:55 pm
Has thanked: 12 times
Been thanked: 20 times

Re: Ich habe folgende Hardware im Müll/Schrott gefunden

Beitrag von False Pr0phet »

TamactiJun hat geschrieben: Do Jun 08, 2023 12:40 pm Super Fund, wann gibt es den Funktionstest ? :D
Ist noch ausstehend
:mrgreen: False ( ͡° ͜ʖ ͡° ) Pr0phet :mrgreen:

Falscher Prophet mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
Status: Don't mess with the False Pr0phet / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
Benutzeravatar
matze79
Norton Commander
Beiträge: 180
Registriert: So Mai 14, 2023 4:50 pm
Wohnort: Oberfranken
Has thanked: 20 times
Been thanked: 34 times
Kontaktdaten:

Re: Ich habe folgende Hardware im Müll/Schrott gefunden

Beitrag von matze79 »

Erwarte schon gespannt den Bericht :D
Benutzeravatar
False Pr0phet
Tape Wechsler
Beiträge: 91
Registriert: Mo Mai 15, 2023 8:55 pm
Has thanked: 12 times
Been thanked: 20 times

Re: Ich habe folgende Hardware im Müll/Schrott gefunden

Beitrag von False Pr0phet »

Und weiter geht es mit dem Festplatten-PCB:

photo_2023-06-12_00-00-31.jpg
photo_2023-06-12_00-00-28.jpg
photo_2023-06-12_00-00-25.jpg
photo_2023-06-12_00-00-21.jpg

Hier bin ich dabei die ICs einzeln herauszulöten - um zu sehen ob die ICs einen Kurzschluss produzieren.
Ein Wert von 53 Ohm besteht aktuell noch immer.

photo_2023-06-12_00-00-12.jpg
Bei diesem Controller-IC ist ein Bein von selbst beim Entlöten herausgefallen und hier musste mit einer Schleifscheibe
der zugehörige Pin freigemacht werden um einen "Patch (TM)" später zu installieren.

Auch hier bleibt der Widerstandswert bei 55 Ohm auf der 5V Leitung.

Die Tantal-ähnlichen Bauteile sind alle laut Messung nicht auf Kurzschluss.

Slow Progress - Wird noch etwas dauern da noch mehr ICs herausgelötet werden müssen um sich dann bei unverändertem
Ohm Wert die anderen Bauteile näher anzuschauen.
:mrgreen: False ( ͡° ͜ʖ ͡° ) Pr0phet :mrgreen:

Falscher Prophet mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
Status: Don't mess with the False Pr0phet / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
Antworten